FreeBSD manual
download PDF document: vt.011.pdf
VT(4) FreeBSD Kernel Interfaces Manual VT(4)
NAME
vt - virtual terminal system video console driver
SYNOPSIS
options TERMINAL_KERN_ATTR=_attribute_
options TERMINAL_NORM_ATTR=_attribute_
options VT_MAXWINDOWS=N
options VT_ALT_TO_ESC_HACK=1
options VT_TWOBUTTON_MOUSE
options VT_FB_MAX_WIDTH=X
options VT_FB_MAX_HEIGHT=Y
options SC_NO_CUTPASTE
device vt
In loader.conf(5):
hw.vga.textmode=1
hw.vga.acpi_ignore_no_vga=1
kern.vty=vt
kern.vt.color.<colornum>.rgb="<colorspec>"
kern.vt.fb.default_mode="<X>x<Y>"
kern.vt.fb.modes.<connector>="<X>x<Y>"
In loader.conf(5) or sysctl.conf(5):
kern.vt.kbd_halt=1
kern.vt.kbd_poweroff=1
kern.vt.kbd_reboot=1
kern.vt.kbd_debug=1
kern.vt.kbd_panic=0
kern.vt.enable_altgr=0
kern.vt.enable_bell=1
DESCRIPTION
The vt device provides multiple virtual terminals with an extensive
feature set:
Unicode UTF-8 text with double-width characters.
Large font maps in graphics mode, including support for Asian
character sets.
Graphics-mode consoles.
Integration with KMS (Kernel Mode Setting) video drivers for
switching between the X Window System and virtual terminals.
Virtual Terminals
Multiple virtual terminals are provided on a single computer. Up to
sixteen virtual terminals can be defined. A single virtual terminal is
connected to the screen and keyboard at a time. Key combinations are
used to select a virtual terminal. Alt-F1 through Alt-F12 correspond to
the first twelve virtual terminals. If more than twelve virtual
terminals are created, Shift-Alt-F1 through Shift-Alt-F4 are used to
switch to the additional terminals.
Copying and Pasting Text with a Mouse
Copying and pasting text from the screen with a mouse is supported.
Press and hold down mouse button 1, usually the left button, while moving
paste button. See moused(8) for more information.
Scrolling Back
Output that has scrolled off the screen can be reviewed by pressing the
Scroll Lock key, then scrolling up and down with the arrow keys. The
Page Up and Page Down keys scroll up or down a full screen at a time.
The Home and End keys jump to the beginning or end of the scrollback
buffer. When finished reviewing, press the Scroll Lock key again to
return to normal use. Some laptop keyboards lack a Scroll Lock key, and
use a special function key sequence (such as Fn + K) to access Scroll
Lock.
DRIVER CONFIGURATION
Kernel Configuration Options
These kernel options control the vt driver.
TERMINAL_NORM_ATTR=attribute
TERMINAL_KERN_ATTR=attribute
These options change the default colors used for normal and
kernel text. Available colors are defined in <sys/terminal.h>.
See EXAMPLES below.
VT_MAXWINDOWS=N
Set the number of virtual terminals to be created to N. The
value defaults to 12.
VT_ALT_TO_ESC_HACK=1
When the Alt key is held down while pressing another key, send
an ESC sequence instead of the Alt key.
VT_TWOBUTTON_MOUSE
If defined, swap the functions of mouse buttons 2 and 3. In
effect, this makes the right-hand mouse button perform a paste.
These options are checked in the order shown.
SC_NO_CUTPASTE
Disable mouse support.
VT_FB_MAX_WIDTH=X
Set the maximum width to X.
VT_FB_MAX_HEIGHT=Y
Set the maximum height to Y.
BACKWARDS COMPATIBILITY
Several options are provided for compatibility with the previous console
device, sc(4). These options will be removed in a future FreeBSD
version.
vt Option Name sc Option Name
TERMINAL_KERN_ATTR SC_KERNEL_CONS_ATTR
TERMINAL_NORM_ATTR SC_NORM_ATTR
VT_TWOBUTTON_MOUSE SC_TWOBUTTON_MOUSE
VT_MAXWINDOWS MAXCONS
none SC_NO_CUTPASTE
START-UP OPERATION WITH X86 BIOS SYSTEMS
The computer BIOS starts in text mode, and the FreeBSD loader(8) runs,
These settings can be entered at the loader(8) prompt or in
loader.conf(5).
hw.vga.textmode
Set to 1 to use virtual terminals in text mode instead of
graphics mode. Features that require graphics mode, like
loadable fonts, will be disabled.
If a KMS driver is loaded the console will switch to (and remain
in) graphics mode.
hw.vga.acpi_ignore_no_vga
Set to 1 to force the usage of the VGA driver regardless of
whether ACPI IAPC_BOOT_ARCH signals no VGA support. Can be used
to workaround firmware bugs in the ACPI tables. Note no VGA
support is only acknowledged when running virtualized. There is
too many broken firmware that wrongly reports no VGA support on
physical hardware.
kern.vty
Set this value to `vt' or `sc' to choose a specific system
console, overriding the default. The GENERIC kernel uses vt when
this value is not set. Note that `sc' is not compatible with
UEFI(8) boot.
kern.vt.color.colornum.rgb
Set this value to override default palette entry for color
colornum which should be in a range from 0 to 15 inclusive. The
value should be either a comma-separated triplet of red, green,
and blue values in a range from 0 to 255 or HTML-like hex
triplet. See EXAMPLES below.
Note: The vt VGA hardware driver does not support palette
configuration.
kern.vt.fb.default_mode
Set this value to a graphic mode to override the default mode
picked by the vt backend. The mode is applied to all output
connectors. This is currently only supported by the vt_fb
backend when it is paired with a KMS video driver.
kern.vt.fb.modes.connector_name
Set this value to a graphic mode to override the default mode
picked by the vt backend. This mode is applied to the output
connector connector_name only. It has precedence over
kern.vt.fb.default_mode. The names of available connector names
can be found in dmesg(8) after loading the KMS driver. It will
contain a list of connectors and their associated tunables. This
is currently only supported by the vt_fb backend when it is
paired with a KMS video driver.
KEYBOARD SYSCTL TUNABLES
These settings control whether certain special key combinations are
enabled or ignored. The specific key combinations can be configured by
using a keymap(5) file.
These settings can be entered at the loader(8) prompt or in
loader.conf(5) and can also be changed at runtime with the sysctl(8)
command.
kern.vt.kbd_poweroff
Enable power off key combination.
kern.vt.kbd_reboot
Enable reboot key combination, usually Ctrl+Alt+Del.
kern.vt.kbd_debug
Enable debug request key combination, usually Ctrl+Alt+Esc.
kern.vt.kbd_panic
Enable panic key combination.
OTHER SYSCTL TUNABLES
These settings can be entered at the loader(8) prompt, set in
loader.conf(5), or changed at runtime with sysctl(8).
kern.vt.enable_bell
Enable the terminal bell.
FILES
/dev/console
/dev/consolectl
/dev/ttyv* virtual terminals
/etc/ttys terminal initialization information
/usr/share/vt/fonts/*.fnt
console fonts
/usr/share/vt/keymaps/*.kbd
keyboard layouts
DEVCTL MESSAGES
System Subsystem Type Description
VT BELL RING Notification that the console bell has
rung.
Variable Meaning
duration_ms Length of time the bell was requested to ring in
milliseconds.
enabled true or false indicating whether or not the bell was
administratively enabled when rung.
hushed true or false indicating whether or not the bell was quieted
by the user when rung.
hz Tone that was requested in Hz.
EXAMPLES
This example changes the default color of normal text to green on a black
background, or black on a green background when reversed. Note that
white space cannot be used inside the attribute string because of the
current implementation of config(8).
options TERMINAL_NORM_ATTR=(FG_GREEN|BG_BLACK)
This line changes the default color of kernel messages to be bright red
on a black background, or black on a bright red background when reversed.
options TERMINAL_KERN_ATTR=(FG_LIGHTRED|BG_BLACK)
To set a 1024x768 mode on all output connectors, put the following line
in /boot/loader.conf:
The connector name was found in dmesg(8):
info: [drm] Connector LVDS-1: get mode from tunables:
info: [drm] - kern.vt.fb.modes.LVDS-1
info: [drm] - kern.vt.fb.default_mode
To set black and white colors of console palette
kern.vt.color.0.rgb="10,10,10"
kern.vt.color.15.rgb="#f0f0f0"
SEE ALSO
kbdcontrol(1), login(1), vidcontrol(1), atkbd(4), atkbdc(4), kbdmux(4),
keyboard(4), screen(4), splash(4), syscons(4), ukbd(4), kbdmap(5),
rc.conf(5), ttys(5), config(8), getty(8), kldload(8), moused(8),
vtfontcvt(8)
HISTORY
The vt driver first appeared in FreeBSD 9.3.
AUTHORS
The vt device driver was developed by Ed Schouten <ed@FreeBSD.org>, Ed
Maste <emaste@FreeBSD.org>, and Aleksandr Rybalko <ray@FreeBSD.org>, with
sponsorship provided by the FreeBSD Foundation. This manual page was
written by Warren Block <wblock@FreeBSD.org>.
CAVEATS
Paste buffer size is limited by the system value {MAX_INPUT}, the number
of bytes that can be stored in the terminal input queue, usually 1024
bytes (see termios(4)).
FreeBSD 14.2-RELEASE July 7, 2024 FreeBSD 14.2-RELEASE