FreeBSD manual

download PDF document: ng_UI.4.pdf

NG_UI(4) FreeBSD Kernel Interfaces Manual NG_UI(4)
NAME ng_UI - UI netgraph node type
SYNOPSIS #include <netgraph/ng_UI.h>
DESCRIPTION The UI node type has two hooks, upstream and downstream. Packets received on downstream must have 0x03 (indicating unnumbered information) as their first byte; if not the packet is dropped. This byte is then stripped and the remainder of the packet sent out on upstream.
Conversely, packets received on upstream will have a 0x03 byte prepended to them before being forwarded out on the downstream hook.
HOOKS This node type supports the following hooks:
downstream Downstream connection. Packets on this side of the node have a 0x03 as their first byte.
upstream Upstream connection. Packets on this side of the node have the initial 0x03 byte stripped off.
CONTROL MESSAGES This node type supports only the generic control messages.
SHUTDOWN This node shuts down upon receipt of a NGM_SHUTDOWN control message, or when both hooks have been disconnected.
SEE ALSO netgraph(4), ngctl(8)
HISTORY The ng_UI node type was implemented in FreeBSD 4.0.
AUTHORS Julian Elischer <julian@FreeBSD.org>
FreeBSD 14.0-RELEASE-p11 January 19, 1999 FreeBSD 14.0-RELEASE-p11