FreeBSD manual

download PDF document: ng_hole.4.pdf

NG_HOLE(4) FreeBSD Kernel Interfaces Manual NG_HOLE(4)
NAME ng_hole - netgraph discard node type
SYNOPSIS #include <sys/types.h> #include <netgraph/ng_hole.h>
DESCRIPTION The hole node type silently discards all data and control messages it receives. This type is used for testing and debugging.
HOOKS A ng_hole node accepts any request to connect, regardless of the hook name, as long as the name is unique.
CONTROL MESSAGES This node type supports the generic control messages, plus the following:
NGM_HOLE_GET_STATS (getstats) This command takes an ASCII string argument, the hook name, and returns the statistics associated with the hook as a struct ng_hole_hookstat.
NGM_HOLE_CLR_STATS (clrstats) This command takes an ASCII string argument, the hook name, and clears the statistics associated with the hook.
NGM_HOLE_GETCLR_STATS (getclrstats) This command is identical to NGM_HOLE_GET_STATS, except that the statistics are also atomically cleared.
SHUTDOWN This node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected.
SEE ALSO netgraph(4), ng_echo(4), ngctl(8)
HISTORY The ng_hole node type was implemented in FreeBSD 4.0.
AUTHORS Julian Elischer <julian@FreeBSD.org>
FreeBSD 14.0-RELEASE-p11 May 19, 2004 FreeBSD 14.0-RELEASE-p11