FreeBSD manual
download PDF document: ng_ubt.4.pdf
NG_UBT(4) FreeBSD Kernel Interfaces Manual NG_UBT(4)
NAME
ng_ubt - Netgraph node type that is also a driver for Bluetooth USB
devices
SYNOPSIS
#include <sys/types.h>
#include <netgraph/bluetooth/include/ng_ubt.h>
DESCRIPTION
The ubt node type is both a persistent Netgraph node type and a driver
for Bluetooth USB devices. It implements a Bluetooth USB transport layer
as per chapter H2 of the Bluetooth Specification Book v1.1. A new node
is created when a supported USB device is plugged in.
The node has a single hook called hook. Incoming bytes received on the
device are re-assembled into HCI frames (according to the length). Full
HCI frames are sent out on the hook. The node will add a HCI frame
indicator if the device did not send it. HCI frames received on hook are
transmitted out. The node will drop the HCI frame indicator unless the
device requires it to be present.
HARDWARE
The ng_ubt driver supports all Bluetooth USB devices that conform with
the Bluetooth specification v1.1, including:
o 3Com 3CREB96
o AIPTEK BR0R02
o EPoX BT-DG02
o Mitsumi Bluetooth USB adapter
o MSI MS-6967
o TDK Bluetooth USB adapter
o Broadcom Bluetooth USB adapter
HOOKS
This node type supports the following hooks:
hook single HCI frame contained in a single mbuf structure.
CONTROL MESSAGES
This node type supports the generic control messages, plus the following:
NGM_UBT_NODE_GET_DEBUG (get_debug)
Returns an integer containing the current debug level for the
node.
NGM_UBT_NODE_SET_DEBUG (set_debug)
This command takes an integer argument and sets the current debug
level for the node.
NGM_UBT_NODE_GET_QLEN (get_qlen)
This command takes a parameter that specifies the queue number
and returns the current maximal length of the queue for the node.
NGM_UBT_NODE_SET_QLEN (set_qlen)
This command takes two parameters that specify the queue number
and the maximum length of the queue and sets the maximal length
of the queue for the node.
Reset all statistic counters to zero.
SHUTDOWN
This node shuts down when the corresponding USB device is un-plugged.
SEE ALSO
netgraph(4), ugen(4), usb(4), ngctl(8)
HISTORY
The ubt node type was implemented in FreeBSD 5.0.
AUTHORS
Maksim Yevmenkin <m_evmenkin@yahoo.com>
BUGS
Isochronous USB transfers are broken. This means that the USB device
will not be able to transfer SCO data (voice). USB interrupt transfers
are implemented as bulk-in transfers (not really a bug).
FreeBSD 14.0-RELEASE-p11 December 26, 2012 FreeBSD 14.0-RELEASE-p11