FreeBSD manual
download PDF document: screen.lua.8.pdf
SCREEN.LUA(8) FreeBSD System Manager's Manual SCREEN.LUA(8)
NAME
screen.lua - FreeBSD screen manipulation module
DESCRIPTION
screen.lua contains functionality for manipulating the screen. This
includes functionality such as clearing the screen, moving the cursor,
and setting foreground/background colors using sequences provided by
color.lua(8).
Before using the functionality provided by screen.lua, it must be
included with a statement such as the following:
local screen = require("screen")
The following variables are exported from screen.lua:
screen.default_x The x component of the default cursor
position.
screen.default_y The y component of the default cursor
position.
The following functions are exported from screen.lua:
screen.clear() Clears the screen. screen.clear() will do nothing
if a serial boot is detected.
screen.setcursor(x, y)
Sets the cursor position to x, y.
screen.setcursor() will do nothing if a serial
boot is detected.
screen.setforeground(color_value)
Sets the foreground color to color_value, which
should be a constant defined in color.lua(8).
screen.setforeground() will do nothing if color is
disabled.
screen.setbackground(color_value)
Sets the background color to color_value, which
should be a constant defined in color.lua(8).
screen.setbackground() will do nothing if color is
disabled.
screen.defcolor()
Sets the default color scheme, as defined by
color.default(). screen.defcolor() will do
nothing if color is disabled.
screen.defcursor()
Sets the default cursor position to that defined
by screen.default_x, screen.default_y.
SEE ALSO
color.lua(8)
AUTHORS