FreeBSD manual
download PDF document: binuptime.9.pdf
MICROUPTIME(9) FreeBSD Kernel Developer's Manual MICROUPTIME(9)
NAME
binuptime, getbinuptime, microuptime, getmicrouptime, nanouptime,
getnanouptime, sbinuptime, getsbinuptime - get the time elapsed since
boot
SYNOPSIS
#include <sys/time.h>
void
binuptime(struct bintime *bt);
void
getbinuptime(struct bintime *bt);
void
microuptime(struct timeval *tv);
void
getmicrouptime(struct timeval *tv);
void
nanouptime(struct timespec *ts);
void
getnanouptime(struct timespec *tsp);
sbintime_t
sbinuptime(void);
sbintime_t
getsbinuptime(void);
DESCRIPTION
The binuptime() and getbinuptime() functions store the time elapsed since
boot as a struct bintime at the address specified by bt. The
microuptime() and getmicrouptime() functions perform the same utility,
but record the elapsed time as a struct timeval instead. Similarly the
nanouptime() and getnanouptime() functions store the elapsed time as a
struct timespec. The sbinuptime() and getsbinuptime() functions return
the time elapsed since boot as a sbintime_t.
The binuptime(), microuptime(), nanouptime(), and sbinuptime() functions
always query the timecounter to return the current time as precisely as
possible. Whereas getbinuptime(), getmicrouptime(), getnanouptime(), and
getsbinuptime() functions are abstractions which return a less precise,
but faster to obtain, time.
The intent of the getbinuptime(), getmicrouptime(), getnanouptime(), and
getsbinuptime() functions is to enforce the user's preference for timer
accuracy versus execution time.
SEE ALSO
bintime(9), get_cyclecount(9), getbintime(9), getmicrotime(9),
getnanotime(9), microtime(9), nanotime(9), tvtohz(9)
AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>.