FreeBSD manual

download PDF document: device_verbose.9.pdf

DEVICE_QUIET(9) FreeBSD Kernel Developer's Manual DEVICE_QUIET(9)
NAME device_quiet, device_verbose, device_is_quiet - manipulate device quiet flag
SYNOPSIS #include <sys/param.h> #include <sys/bus.h>
void device_quiet(device_t dev);
void device_verbose(device_t dev);
int device_is_quiet(device_t dev);
DESCRIPTION Each device has a quiet flag associated with it. A device is verbose by default when it is created but may be quieted to prevent printing of the device identification string during attach and printing of a message during detach. To quiet a device, call device_quiet() during a device driver probe routine. To re-enable probe messages, call device_verbose(). To test to see if a device is quieted, call device_is_quiet().
Devices are implicitly marked verbose after a driver detaches.
SEE ALSO device(9)
AUTHORS This manual page was written by Doug Rabson.
FreeBSD 14.0-RELEASE-p6 September 12, 2016 FreeBSD 14.0-RELEASE-p6