FreeBSD manual

download PDF document: pmap_remove_pages.9.pdf

PMAP_REMOVE(9) FreeBSD Kernel Developer's Manual PMAP_REMOVE(9)
NAME pmap_remove, pmap_remove_all, pmap_remove_pages - remove pages from a physical map
SYNOPSIS #include <sys/param.h> #include <vm/vm.h> #include <vm/pmap.h>
void pmap_remove(pmap_t pmap, vm_offset_t sva, vm_offset_t eva);
void pmap_remove_all(vm_page_t m);
void pmap_remove_pages(pmap_t pmap);
DESCRIPTION The pmap_remove() function removes the range of addresses between sva and eva from the physical map pmap. If eva is less than sva, then the result is undefined. It is assumed that both sva and eva are page-aligned addresses.
The pmap_remove_all() removes the physical page m from all physical maps in which it resides, and reflects back the modify bits to the appropriate pager.
The pmap_remove_pages() function removes all user pages from the physical map pmap. This function is called when a process exits to run down its address space more quickly than would be the case for calling pmap_remove().
SEE ALSO pmap(9)
AUTHORS This manual page was written by Bruce M Simpson <bms@spc.org>.
FreeBSD 14.0-RELEASE-p6 July 21, 2003 FreeBSD 14.0-RELEASE-p6