FreeBSD manual

download PDF document: vfs_getnewfsid.9.pdf

VFS_GETNEWFSID(9) FreeBSD Kernel Developer's Manual VFS_GETNEWFSID(9)
NAME vfs_getnewfsid - allocate a new file system identifier
SYNOPSIS #include <sys/param.h> #include <sys/mount.h>
void vfs_getnewfsid(struct mount *mp);
DESCRIPTION The vfs_getnewfsid() function allocates a new file system identifier for the mount point given. File systems typically call vfs_getnewfsid() in their mount routine in order to acquire a unique ID within the system which can later be used to uniquely identify the file system via calls such as vfs_getvfs(9).
The actual fsid is made up of two 32 bit integers, that are stored in the statfs structure of mp. The first integer is unique in the set of mounted file systems, while the second holds the file system type.
typedef struct fsid { int32_t val[2]; } fsid_t;
PSEUDOCODE xxx_mount(struct mount *mp, char *path, caddr_t data, struct nameidata *ndp, struct thread *td) { ... vfs_getnewfsid(mp); ... }
SEE ALSO vfs_getvfs(9)
AUTHORS This manual page was written by Chad David <davidc@acns.ab.ca>.
FreeBSD 14.2-RELEASE November 21, 2001 FreeBSD 14.2-RELEASE