FreeBSD manual

download PDF document: vn_isdisk.9.pdf

VN_ISDISK(9) FreeBSD Kernel Developer's Manual VN_ISDISK(9)
NAME vn_isdisk - checks if a vnode represents a disk
SYNOPSIS #include <sys/param.h> #include <sys/vnode.h>
bool vn_isdisk(struct vnode *vp);
bool vn_isdisk_error(struct vnode *vp, int *errp);
DESCRIPTION The vn_isdisk() and vn_isdisk_error() functions check to see if vp represents a disk. In order for vp to be a disk, it must be a character device, v_rdev must be valid, and the cdevsw entry's flags must have D_DISK set.
The arguments are:
vp The vnode to check.
errp An integer pointer to store the error number in if the call fails.
RETURN VALUES If the vnode represents a disk, true is returned; otherwise, false is returned and errp will contain the error number.
AUTHORS This manual page was written by Chad David <davidc@acns.ab.ca>.
FreeBSD 14.0-RELEASE-p6 June 28, 2021 FreeBSD 14.0-RELEASE-p6