FreeBSD manual
download PDF document: password.lua.8.pdf
PASSWORD.LUA(8) FreeBSD System Manager's Manual PASSWORD.LUA(8)
NAME
password.lua - FreeBSD password module
DESCRIPTION
password.lua contains functionality for prompting for and checking
passwords.
Before using the functionality provided by password.lua, it must be
included with a statement such as the following:
local password = require("password")
The following functions are exported from password.lua:
password.read(prompt_length) Read a password following a prompt.
prompt_length is required so that
the twiddle may be properly drawn
as the user is typing.
password.check() Drives the primary password checks
done by the loader. The
password.check() function will
check bootlock_password,
geom_eli_passphrase_prompt, and
password and prompt the user for
passwords as-needed. If password
is set, the autoboot sequence will
begin as the user is prompted for a
password.
SEE ALSO
screen.lua(8)
AUTHORS
The password.lua file was originally written by Pedro Souza
<pedrosouza@FreeBSD.org>. Later work and this manual page was done by
Kyle Evans <kevans@FreeBSD.org>.
FreeBSD 14.2-RELEASE August 19, 2018 FreeBSD 14.2-RELEASE